Home MadLab   Doc Menus & toolbar
Menus and toolbar etc.
 

MadLab commands are launched in these typical ways:

 

Using the toolbar buttons

 

 ...

...

 

These buttons activate the most frequently used commands.

 

 Create new game

Creates a new game/board of given size up to 19x19. MadLab can operate with several boards at the same time.

Also available from the menu: "File" --> "New..."

 

 Open sgf file

Opens the specified sgf file. MadLab only understands sgf (Smart Go Format), and only to a limited degree. It supports most sgf syntax, and indeed reads most sgf files (including Kogo's joseki dictionary), but at the present stage I cannot guarantee that MadLab can parse any sgf file especially if the file contains inconsistencies.

Also available from the menu: "File" --> "Open..."

 

 Save

Saves the game as a sgf file. MadLab cannot save in any other format.

Also available from the menu: "File" --> "Save"

 

 Go to start of game

Also available from the keyboard: "Home" key.

 

 Go back 10 moves

Also available from the keyboard: "Page Up" key.

 

 Go back 1 move

Also available from the keyboard: Up arrow.

 

 Go to alternate to current move

If the game tree branches, there may be one or more alternatives to the current move (siblings). Pushing this button toggles circularly through the alternatives. You can have alternative moves (siblings) depicted on the board via "View" --> "Show next move(s)".

 

 Go one move forwards

Also available from the keyboard: Down arrow.

 

 Go 10 moves forwards

Also available from the keyboard: "Page Down" key.

 

 Go to end of game

Also available from the keyboard: "End" key.

 

 Delete last move

This is usful when playing out variations, and you do not want the variations to be kept in the game tree.

Also available from the keyboard: "Backspace" key.

 

 /  Pass move

The player to move (= same color as the icon) plays a pass move. You can also use this to change the color to move next.

 

 Search: Obtain goal

If one or more goals (e.g. capturing at least one of two blocks of stones) is set, hitting this button will start the MadLab search engine. If no goal is set, you should first set the goal(s) by clicking the drop-down symbol  (located next to the  button). Alternatively you may right-click a stone and use the popup menu to launch a search.

Also available from the menu: "Actions" --> "Search: Obtain goal".

See also menu "View" --> "Show thinking".

 

 Stop search

This terminates any search at the current board, whether it be obtaining goals, avoiding goals, or analyzing a game.

Also available from the menu: "Actions" --> "Stop search".

 

 Search: Avoid goal

This is the complementary to obtaining goals. In the context of capturing a block of stones, avoiding that goal means escaping from capture. During this search, possible avoiding moves are depicted green meaning that the move avoids an attack (of the given lambda-order), and yellow meaning that the move awaits further analysis (grey means that the move has not been analyzed yet). Moves that are not marked are proved not to work. If the search is stopped by hitting the stop button, the most resistive move is played.

Also available from the menu: "Actions" --> "Search: Avoid goal".

 

 Set search goals(s)

This opens up a window in which search goals (and maximal lambda-order) can be entered. In order to set up goals from scratch, first choose the number of goals. Next click the "Type" field, and follow the instruction given in the "Stone(s)" field. Note: For simple goals like capture of one or two blocks of stones, it is easier to start the search by right-clicking a stone and use the popup menu.

Also available from the menu: "Options" --> "Set search goal(s)..."

 

 Add black or white stone(s)

Adds (or removes) any black of white stones(s) anywhere on the board. To add a black stone, click once on the board, and to add a white stone click twice. Stones may also be removed by clicking once more. This facility works in any position, not just the starting position. In the starting position, it may be used to set up handicap stones. The most common use, however, is for entering go problems for MadLab to solve.

 

 Mark triangle

Puts a triangle at the specified intersection. Click once more to remove it.

 

 Mark square

Puts a square at the specified intersection. Click once more to remove it.

 

 Mark circle

Puts a (red) circle at the specified intersection. Click once more to remove it.

 

 Mark cross

Puts a cross at the specified intersection. Click once more to remove it.

 

 Mark text

Puts a text label at the specified intersection. Insert an empty text label to remove a label.

 

 Open previous sgf file

Closes the current board and opens the previous sgf file (following intelligent alphabetical order where "a2" comes before "a10").

Also available from the menu: "File" --> "Get previous sgf"

 

 Open next sgf file

Closes the current board and opens the following sgf file. Useful when solving the 997 MadLab problems, in order to quickly pick the next problem.

Also available from the menu: "File" --> "Get next sgf"

 

 Show game info

Shows info about the game. The last column is the two-letter sgf code. Double-click to change values.

Also available from the menu: "View" --> "Show game info"


Using the menu

 

 

----------------- File menu ------------------

File --> New...

Opens up a new empty board. Also available from the toolbar: .

 

File --> Open...

Opens up a new board from a sgf file. Also available from the toolbar: .

 

File --> Open problems...

Takes you to the folder with the 997 MadLab-verified tesuji problems. You can read more about those here.

 

File --> Open previous sgf

Closes the current board and opens the previous sgf file (following intelligent alphabetical order where "a2" comes before "a10"). Also available from the toolbar: .

 

File --> Open next sgf

Closes the current board and opens the following sgf file. Convenient when solving the 997 MadLab problems. Also available from the toolbar:.

 

File --> Save.

Saves the current game as a sgf file. Also available from the toolbar: .

 

File --> Save as...

Saves the current game to a specified sgf file.

 

File --> Close Board

Closes the current board.

 

File --> Exit program

Exits MadLab.

 

----------------- Actions menu ------------------

 

Actions --> Analyze game...

This analyzes a whole game, checking it for the presence of single- or double-goal captures. You can impose limits on the number of nodes per problem, and the maximal lambda-order. Note that analyze does not work with added stones (setup stones), except at the root node (this means that handicap stones are ok). After analyze has finished, you can go through the game to see if you missed any tesuji's.

 

Actions --> Search: Obtain goal

Tries to obtain the goal (regarding goals, see "Options" --> "Set search options"). Also available from the toolbar: .

 

Actions --> Search: Avoid goal

Tries to avoid that the other player obtains the goal (regarding goals, see "Options" --> "Set search options"). Also available from the toolbar:

Actions --> Stop search

Stops search or analysis on the current board. Also available from the toolbar: .

 

Actions --> Clear memorized moves

When MadLab solves a problem (obtains a goal, e.g. captures a block of stones), it stores some of the moves in memory, in order to respond quickly when the user later explores sub-variations. This memorization is only done for harder problems, but sometimes you may be interested in seeing MadLab performing a fresh search, even though it knows the answer already. If so, this menu item clears all memorized moves.

See also: "Options" --> "General options" --> "Memorize moves when solving problems".

 

----------------- Options menu ------------------

 

Options --> Play mode

In play mode, you can have MadLab "play" one of the sides. This means that after each move by you, MadLab will automatically launch a new search (so that you avoid hitting the  or  button). This is practical when navigating through a large number of moves/variations in larger problems, since it means that you do not need to hit the search button all the time in order to have the solution demonstrated.

 

Options --> Set search goals(s)...

Also available from the toolbar: .

 

Options --> Memory & search options...

In this window, you can set some important memory and search options. Regarding these parameters, you may want to read this page.

 

Options --> Ko options...

MadLab can solve ko problems if you donate external ko-threats to one of the players. If, for instance, one player can capture the other with two external ko threats, you may donate these threats here, in order for MadLab to solve the problem. For more on this, see this ko-example. It should be noted that MadLab uses the super ko rule (a position with the same player to move may not be recreated).

 

Options --> General options...

In this window, a number of general options can be set, mostly related to the graphical user interface.

 

Options --> Reset all options...

This will reset all options you have set, reverting MadLab to the settings it had when you launched it for the first time. You will have to close and restart MadLab in the process of doing this.

 

----------------- View menu ------------------

 

View --> Zoom, shadow...

The size of the board/stones can be set, including the size of the stone shadows.

 

View --> Show next move(s)

When activated, the next moves in the game tree (sgf file) are shown on the board. This is practical for navigating through a tree of variations, like in Kogo's Joseki Dictionary.

 

View --> Show thinking

During search the variations that MadLab is considering are shown. Depending upon your graphics card this may slow down MadLab a bit.

 

View --> Show game info...

Shows info about the game.

Also available from the toolbar: .

 

----------------- Window menu ------------------

 

Window --> <filenames>

In this menu you can switch between boards.

 

----------------- Help menu ------------------

 

Help --> Help topics...

This launches the MadLab documentation/manual.

 

Help --> About MadLab...

Information about the MadLab version, Java version, memory settings, folders, etc.

 


Popup-menu (right-clicking a stone)

When right-clicking a stone on the board, the above menu pops up. If you choose "Capture", MadLab tries to capture the stone (or block of stones).

If you right-click on a stone and choose "Capture 1 of 2...", you can drag the depicted line to another stone of same color and left-click. This will start a double-threat search, where MadLab tries to capture either of the two blocks of stones.

If you right-click on a stone and choose "Connect...", you can drag the depicted line to another stone of the same color and left-click. MadLab will try to connect the two blocks of stones.

"Make 1 eye" and "Make 2 eyes" try to make eyes for the considered block of stones.

The last two commands try to avoid goals. "Escape" tries to avoid capture, whereas "Escape both..." tries to avoid a double-threat tesuji. "Disconnect..." tries to avoid connection. When choosing the last two of these, you should drag the line to another stone of the same color and left-click.

 


Keyboard

You can use the keyboard for convenient navigation through a game record. Up arrow and Down arrow move backwards and forwards, whereas 'Page Up' and 'Page Down' move 10 moves backwards and forwards. 'Home' moves to the start of the game, and 'End' moves to the end. 'Backspace' deletes the last move. Left arrow and Right arrow toggles between variations (alternates to current move, if any).